fiksna Error: Vaš PHP installZdi se, da manjka razširitev MySQL, ki jo zahteva WordPress

"Vaš PHP installZdi se, da manjka razširitev MySQL, ki jo zahteva WordPress”Je napaka, s katero se srečujejo številni lastniki blogov in spletnih strani WordPress.
To ne povzroča skrbi. Pomanjkanje razširitve MySQL od PHP je značilno za operacijske sisteme, nameščene iz nič, VPS ali namenske strežnike, kjer razširitve PHP niso bile del namestitvenega paketa. Ta težava je prisotna pri obeh Ubuntu in CentOS. V tem primeru je težava zelo preprosto rešena s posodobitvijo PHP in namestitvijo modula "php-mysql".
Posodobite PHP in namestite MySQL razširitev na Ubuntu

apt-get update
apt-get install php-mysql

Posodobite PHP in namestite MySQL končnico na CentOS

yum update
yum install php70w-mysql

Po tem koraku restartimate storitev Apache ali nginx.

Naletel sem tudi na scenarij, v katerem, čeprav razširitev MySQL obstaja v PHP, je blog, ustvarjen na WordPressu, prikazal napako »Vaš PHP installZdi se, da manjka razširitev MySQL, ki jo zahteva WordPress. " Napaka se največkrat pojavi pri namestitvi WordPressa. Tokrat pa se je pojavil na blogu, ki je bil aktiven že nekaj let.
V tej situaciji sem ugotovil, da težava ni v modulih PHP, temveč v zelo stari različici WordPress, ki v PHP 7.4.4RC1 ni več združljiva. Preprosta nadgradnja programa WordPress na najnovejšo različico je rešila napako.

Navdušen sem nad tehnologijo, rad preizkušam in pišem vaje o operacijskih sistemih macOS, Linux, Windows, o WordPressu, WooCommerceu in konfiguraciji spletnega strežnika LEMP (Linux, NGINX, MySQL in PHP). Pišem naprej StealthSettings.com od leta 2006, nekaj let kasneje pa sem začel pisati na iHowTo.Tips vadnice in novice o napravah v ekosistemu Apple: iPhone, iPad, Apple Watch, HomePod, iMac, MacBook, AirPods in dodatki.

Pustite komentar