FIX PROBLEM: Vaš strežnik teče različico PHP vendar WordPress 5.1.6 3.2.1 5.2.4 potrebuje najmanj.

Obvestilo za vse ni znano, da je za namestitev ali pa nadgradnjaNa novejšo različico 3.2Potrebno je, da namestiti novejšo različico 5.2.4.

Če strežnik namestiti različico PHP starejše od 5.2.4, namestitev različice WordPress 3.2.1Se bo pojavil napaka / sporočilo: "Vaš strežnik teče PHP različice WordPress 5.1.6 3.2.1 pa potrebuje vsaj 5.2.4".
Problem je mogoče rešiti zelo preprosto z nadgradnjo PHP, toda pred tem je treba upoštevati nekaj stvari. Prvič, nadgradite PHP je na deljeno gostovanje mogoče. Zato lahko naredite nadgradnjo, morate imeti skrbniški dostop do strežnika (Dedicated Server ali VPS). V drugem, pred nadgradnjo treba dokumentirati in se zavedati, da je Nova različica PHP ne da bi napake drugih spletnih strani gostuje na tem strežniku.

Za operacijski sistem se uporablja za spletni strežniki (Agreart in / WHM) Vam bo pokazal, kako narediti nadgradnja na PHP na CentOS 5.2.10.x 5 32-bitno.

Nadgraditi PHP na CentOS 5.1.x 5.2.x za 5.x 32-bitno

1. Preverite, kateri paketi / moduli, ki so nameščeni PHP (npr. php-Mcrypt) poleg standardnega paketa. Če obstajajo, bodo izbrisani ali actuzlizate.

Preverjanje nameščene pakete:

rpm -qa | grep php
old_php_version

2. Če želite dodati dodatne repozitorije Potrebna nadgradnja'S PHP verzijo.

nano /etc/yum.repos.d/CentOS-Testing.repo

Nova datoteka (CentOS-Testing.repo) Bo dodajte naslednje vrstice (copy / paste):

[c5-testing] 
name=CentOS-5 Testing 
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/ 
enabled=1 
gpgcheck=1 
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing 
includepkgs=php*

Ctrl + X da shranite datoteko CentOS-Testing.repo.

3. Posodobitev PHP preko yum:

yum update

4. Restart / httpd :

service httpd restart

Po restart httpd preverite nameščeno različico in pakete:

new_php_version

Preverite za napake modulov / paketov:

php -v

- PHP Nadgradnja / CentOS 32-bitni (i386).

Ustanovitelj in urednik Stealth Settings, od leta 2006 do danes. Izkušnje z operacijskimi sistemi Linux (zlasti CentOS), Mac OS X, Windows XP> Windows 10 in WordPress (CMS).

Pustite komentar